All MDA services should now be working after Friday's worldwide vendor technology outage. We apologize for any inconvenience this may have caused.

In order to Apply or Renew a license online, we suggest you use Internet Explorer version 11 or higher, Firefox version 52 or higher, Safari version 10 or higher. We are currently experiencing issues with Google Chrome, version 57 and higher, and you may experience issues with this browser. All older browsers are currently not supported due to security issues with those browsers.