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Version 1  

This manual is designed to accompany lecture and handout materials provided at a series of 
workshops offered in multiple Minnesota locations in 2010, as part of a Precision Conservation 
project administered by the Minnesota Department of Agriculture with Clean Water Funds.  The 
Precision Conservation project aims to help locally led clean water restoration and protection 
projects target critical areas of the landscape where conservation treatments will be most 
effective in meeting water quality goals.   
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Exercise 1: LiDAR DEM Data  

A. Basic Properties - Examining Source Data  

1. Start ArcMap.  

2. Add to your map the raster of our area of interest as a new layer. 

3. Click the name of the layer in the map Table of Contents and rename it DEM.   

4. Select this DEM Layer again, right-click > Properties. 

o Click the Source tab in the properties for the layer to get a full description 

of the layer including cell size, format, extent and spatial reference. 

o Now click the Symbology tab.  Here you can change the color ramp.  

 Workshop demonstration - colormap and stretch-type adjustments 

o Check-on the Hillshade option to emphasize the terrain features. This 

does not affect the analysis or change the data, but aids in visualization. 

o Once you have examined all layer properties, click OK to close the layer 

properties. 
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B. DEM and Hydrologic Conditioning  

Activate Spatial Analyst Extension 

1. From the Tools Menu, select Extensions and check Spatial Analyst. 

 

2. Click Close. 
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Pit Filling 

1. Launch ArcToolbox by clicking the toolbar icon.  

2. Expand the Spatial Analyst Tools, then expand the Hydrology Toolset. 

Double-click the Fill tool to start it. 

TIP:  There are several other ways to find this (or any) tool in 

ArcToolBox: 

 Select the Index tab at the bottom of ArcToolbox and scroll 

through the list to find Fill (sa).  

 Select the Search tab at the bottom and type in fill to find any 

tools with 'fill' in their titles. 

 

3. Input Surface Raster: DEM (select it from the drop-down). 

4. Output Surface Raster: Browse to output workspace and name fill_dem 

5. Z limit: the maximum elevation difference between a sink and its pour point to be 

filled.  

o Note: The default will fill all sinks regardless of depth.  

6. The output surface raster is added to your map as a new layer.   
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Filter Analysis 

At times, LiDAR data expressed in fine-resolution DEMs can contain either errors or 

spurious features which impede flow analysis and/or other terrain analysis.  Using a 

moving-window 3X3 grid can "smooth" the data and provide more contiguous results.   

1. ArcToolbox > Spatial Analyst Tools > Neighborhood > Filter. 

 

2. Input Raster: DEM (select it from the drop-down list). 

3. Output Raster: Browse to your output workspace and name it filter_dem 

4. Filter type (optional): the enhancement to be performed in the filter analysis.  

Note: The default is LOW which is needed to do the smoothing we require.  

5. The output raster is added to your map as a new layer.   
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Exercise 2: Terrain Attributes and Calculations 

A. Calculate Primary Attributes  

Slope  

1. ArcToolbox > Spatial Analyst Tools > Surface > Slope. 

 

2. Input Raster: DEM. 

3. Browse to output workspace and name output layer slope_dem 

4. Select Output Measurement: PERCENT_RISE 

Note: It is important for the rest of the analysis that you select 

PERCENT_RISE, even though the data will look the same.  

5. Click OK to run.  

6. The output raster is added to the map as a new layer.  
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Aspect  

1. ArcToolbox > Spatial Analyst Tools > Surface > Aspect. 

 

2. Input Raster: DEM. 

3. Browse to output workspace and name the output raster aspect_dem 

4. Click OK to run.  

5. The output will be added to the map as a new layer.  
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Plan and Profile Curvature  

1. ArcToolbox > Spatial Analyst Tools > Surface > Curvature. 

 

2. Input Raster: DEM. 

3. Browse to output workspace and name the output curvature raster curv_dem 

4. Browse to output workspace and name the profile curve raster profil_dem 

5. Browse to output workspace and name the plan curve raster plan_dem 

6. Click OK to run. 

7. The 3 output rasters are added to the map as new layers. 
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Hillshade 

1. ArcToolbox > Spatial Analyst Tools > Surface > Hillshade. 

 

2. Input Raster: DEM. 

3. Browse to your output workspace and name the output raster hs_dem 

4. Accept defaults for Azimuth, Altitude and Z factor. 

Note: You can try checking on Model Shadows, which can aid visualization 

however, in some cases, it makes little difference. 

5. Click OK to run. 

6. The output raster is added to the map as new layer. 
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Flow Direction  

1.  ArcToolbox > Spatial Analyst Tools > Hydrology > Flow Direction. 

 

 

2. Input Raster: DEM 

3. Browse to your output workspace and name output layer FlowDir_dem 

4. Click OK to run.  

5. The output raster is added to the map as a new layer.   
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Flow Accumulation (using output from Flow Direction)  

1. ArcToolbox > Spatial Analyst Tools > Hydrology > Flow Accumulation. 

 

2. For Input Flow Direction Raster, use the output of Flow Direction from earlier 

step.  If you kept the suggested name, it will be "FlowDir_dem". 

3. Browse to output workspace and name the output raster FlowAcc_dem. 

4. You can accept defaults for the other factors. 

5. Click OK to run. 

6. The output raster is added to the map as a new layer. 
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B. Calculate Secondary Attributes  

Stream Power Index (SPI)  

SPI = LN(([FlowAcc_Dem] + 0.001) * (([Slope_Dem] / 100) + 0.001)) 
 

1. From the Spatial Analyst Toolbar, open the Raster Calculator. 

 

2. Enter formula so the result looks like the example in the screenshot below (next 

page). 

3. Click Evaluate to run the calculation. 

4. The output is Temporary and will be added to the map layers as "Calculation".  

5. Select the layer in the map Table of Contents and rename it as SPI_Calc. 

6. To save it, select the layer, right-click and choose Data > Export. Set the file 

type to export as GRID rather than the default of Imagine IMG.  
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Compound Topographic Index (CTI)    

CTI = LN(([FlowAcc_Dem] + 0.001) / (([Slope_Dem] / 100) + 0.001))  
 

1. From the Spatial Analyst Toolbar, open the Raster Calculator. 

2. Enter formula so the result looks like the example in the screenshot below. 

TIP / SHORTCUT: The CTI formula is almost identical to the Stream Power 

Index (SPI) formula, so you can shortcut the formula entry process by copying 

and pasting the SPI formula you entered in the previous exercise. 

 To do this, place your cursor anywhere in the formula entry box, right-click 

and choose Recently Used Formulas.  Select the formula previously entered 

(in this case, the formula used to calculate SPI).  Copy and paste this into the 

current formula entry box.  To calculate CPI, change the multiplication 

symbol ( *  ) to the division symbol (  /  ). 

3. Click Evaluate to run the calculation. 

4. The output is Temporary and will be added to the map layers as "Calculation" or 

"Calculation2".  

5. Select the layer in the map Table of Contents and rename it as CTI_Calc. 

6. To save it, select the layer, right-click and choose Data > Export. Set the file 

type to export as GRID rather than the default of Imagine IMG. 
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Exercise 3: Interpretation     

A. Visualization / Comparative Techniques  

Terrain Attribute Comparison 

Often, the best way to understand differences in terrain attribute calculations is to view 

each layer in conjunction with other layers.  By paying careful attention to a specific 

portion of the landscape, one can overlay each of the terrain attributes to gain a better 

understanding each attribute's value. 

Orthophoto/Terrain Attribute Comparison 

Add MNGEO WMS Service: 

1. Open ArcMap and click on Add Data.  

2. Look in the Catalog and click on GIS Servers.  

3. Highlight Add WMS Server so it appears in the Name window, and hit Add. 

 An 'Add WMS Server' window will pop up.  

4. To bring up the Imagery server, type http://geoint.lmic.state.mn.us/cgi-bin/wms?  

in the URL window. You can click on the Layers button to see a list of the layers 

available under the wms.  Click OK.  

5. To bring up the Scanned DRG server, type http://geoint.lmic.state.mn.us/cgi-bin/wmsz? 

in the URL window.  You can hit the Get Layers button to see a list of the layers 

available under the wms.  Click OK.  

6. Now when you look under 'GIS Servers' you have two new entries: 

 'LMIC WMS server (aerial photography) on geoint.lmic.state.mn.us' 

 and  'LMIC WMS  server (quad sheet drgs) on geoint.lmic.state.mn.us'  

7. Still in the 'Add Data' window under 'GIS Servers', highlight one of the services 

listed under #6 to bring it into the 'Name' window,  then click on Add. 

 The service, with all of its layers, has now been added to your ArcMap project.  

8. Click on '+' to open the map service and get on the layers.  Check them on and 

off as needed.  Click on '-' to close. 
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Swipe  

1. To display the Effects Toolbar, right-click and select View Menu > Toolbars > Effects. 

2. To "swipe" a layer using a horizontal or vertical line across the screen, select the 

Swipe Tool (outlined in red in the screenshot below). 

 

3. Make sure the layer you want to "swipe" is shown in the "Layer:" box. 

4. Click on the map and drag to swipe (do not release mouse button; the mouse must 

be depressed to get the swipe effect.) 

  

See example of swipe below: 
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Specific Colormaps for each Terrain Attribute 

Often this is a matter of personal preference, but there are a few tips/tricks in display 

used for specific terrain attributes. 

 Slope - Colormap variations 

 Flow Accumulation - Visualize upslope contributing area as if it were a watershed 

boundary 

 CTI - Blue/Water - display highest values 

 SPI - Brown/Sediment - display highest values 

 

 

 

 

B. Determining Thresholds   

Threshold Value Display 

1. Add to your map the raster of our area of interest as a new layer. 

2. Click the name of the layer in the map Table of Contents and rename it: DEM.   

3. Select this DEM Layer again, right-click > Properties. 

a. Now click the Symbology tab.  Here you can change the color ramp.  

i. Workshop demonstration - colormap and stretch-type adjustments 

  



 

Workshop Exercises for “Digital Terrain Analysis 
with LiDAR for Clean Water Implementation”  

 

19 | P a g e          Copyright 2010 Minnesota Department of Agriculture                  
 

Percentile Analysis 

1. ArcToolbox > Conversion Tools>From Raster>Raster to ASCII. 

2. Input Raster:  Layer of interest (select from drop-down list). 

3. Output ASCII file:  Browse to your output workspace and name it percentile 

4. Field (optional):  

5. Open Excel 

6. Open the ASCII file you just created. 

Note: In Files of Type, select All Files (*.*)  from the drop-down menu, so the 

ASCII file will be displayed. 

7. In the Import file wizard: 

 Select delimited 

 Check the space option 

 Click Next 

 Click Finish to import the file. 

8. DON’T CALCULATE 

9. Add previously calculated dataset as directed 

10. In  Excel: 

 Note Max records affect ability to input LiDAR data into Excel 

 Excel 2003 max records - 65,569 

 Excel 2007 max records - 1,048,575 

 Statistical Packages – Many around 10 milion 

11. Open “percentile_point.dbf” 

Select unused cell and type =percentile(array, k)  

 Where array is the highlighted column with point values 

 Where “k” is the percentile of interest – e.g. 0.85 

Please feel free to continue to work on these data and ask questions as you go. 

GENERAL QUESTIONS? 


